Basic workflow 2D

From ShapeOko
Revision as of 10:10, 28 August 2012 by Edward (Talk | contribs) (Created page with "Basic 2D Workflow via Fully Open Source CAD/CAM Stack ==Create part file with Inkscape== Great path from text, ungroup [[File:9_sh...")

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

Basic 2D Workflow via Fully Open Source CAD/CAM Stack

Create part file with Inkscape

Great path from text, ungroup
Show Rule in HeeksCNC
Split Sketch
Apply profile toolpath
View toolpaths


  1. Open Inkscape
  2. Create Text with text tool (scale your text to the size you want)
  3. Select your text (with the arrow) and move it to X=0, Y=0 via the menu bar
  4. With the text selected, click Path -> Object to Path
  5. Ungroup your new paths, click Object -> Ungroup (you'll notice each letter now has a box around it)
  6. Save your file as DXF via the Big Blue Saw Plugin (*.DXF), close inkscape

Create toolpaths with HeeksCNC

  1. Open your STP file
  2. Right Click on face of Solid.
  3. Select Face -> Make a sketch from Face
  4. Right click on the sketch in left pane, select 'Split Sketch' - You now have two seperate sketches
  5. Select the inside profile (outline will turn darker)
  6. Click Machining -> Add New Milling Operation -> Pocket Operation -> Fill in details -> Click OK (or apply?)
  7. Click Machining -> G0 (Post Process) - your toolpath will show (DOS box pops up, then disapears)
  8. Select the outside profile (outline will turn darker)
  9. Click Machining -> Add New Milling Operation -> Profile Operation (no window pops up) - control output via Properties pane in lower left
  10. Select 'Outside' for 'Tool on Side'
  11. Make sure your final depth is the thickness of your material.
  12. Select the appropriate tool
  13. Click Machining -> G0 (Post Process) - your toolpath will show (DOS box pops up, then disapears)
  14. At the bottom of your screen you will see the actual g-code output. You can copy and paste that to a text file. OR, click Machining -> Save nc File.

Simulate toolpaths with OpenSCAM

  1. Click File-> Open
  2. Find the NC file you saved from HeeksCNC
  3. OpenSCAM will process the file, resulting in what the part will look like *finished*
  4. There is a slider bar in the middle of the left hand window, slide that all the way to the left. Toggle the direction arrow to the right
  5. Click Edit -> Project
  6. Add a new tool: Click +, define tool at 10mm length 3.175mm diameter. Make note of the tool number!
  7. Open your NC file and find out what tool it's expecting to find. Towards the top you'll see the T command. Maybe T16?
  8. In the NC file, change the T# to match the tool you just created in OpenSCAM. Save your NC file. You will notice OpenSCAM re-rendering the toolpaths to accomdate the change in cutter size.
  9. Switching back over to OpenSCAM: Click the 'Play Button' under the 'Animate Toolpath' Section.
  10. Watch in amazement!
  11. If you are impatient, click the fast forward button, directly to the right of the 'Play button' to speed things up.

Run your job with Universal Gcode Sender

  1. Browse for the NC file we just simulated
  2. next step...