Basic workflow 2D

From ShapeOko
Revision as of 12:43, 23 November 2012 by Glennpowers (Talk | contribs) (fixed link)

Jump to: navigation, search

Basic 2D Workflow via Fully Open Source CAD/CAM Stack

Create part file with Inkscape

Great path from text, ungroup
Show Rule in HeeksCNC
Split Sketch
Apply profile toolpath
View toolpaths
Generated Toolpaths
  1. Open Inkscape
  2. Create Text with text tool (scale your text to the size you want)
  3. Select your text (with the arrow) and move it to X=0, Y=0 via the menu bar (shown in red rectangle -> )
  4. With the text selected, click Path -> Object to Path
  5. Ungroup your new paths, click Object -> Ungroup (you'll notice each letter now has a box around it)
  6. Save your file as DXF via the Big Blue Saw Plugin (*.DXF), close inkscape

Create toolpaths with HeeksCNC

  1. Click File-> Import, browse and open the DXF file created in step 6
  2. You may have to rescale your drawing. I find it easiest to make the ruler visable as a reference, the ruler is available in cm only.
  3. On the left hand toolbar, Right click "ENTITIES Layer_1" and select "Split Sketch", this will create a seperate object for each of your letters.
  4. Select all of the letters
  5. With the letters highlighted, click the "Profile Operation" button, this will produce a new operation called "Profile" under the Operations section on the left hand side of the screen. Highlight the new operation to expose it's properties.
  6. To do an engrave function (what we would want if drawing with a pen), select the value on for the tool on side option. Click the green check mark at the bottom to apply the settings. Change the final depth to -0.1 (you may have to adjust this depending on what marking device you're using)
  7. To generate the toolpath, click G0. Your toolpaths will turn green
  8. At the bottom of your screen you will see the actual g-code output. You can copy and paste that to a text file. OR, click Machining -> Save nc File.

Simulate toolpaths with OpenSCAM

  1. Click File-> Open
  2. Find the NC file you saved from HeeksCNC
  3. OpenSCAM will process the file, resulting in what the part will look like *finished*
  4. There is a slider bar in the middle of the left hand window, slide that all the way to the left. Toggle the direction arrow to the right
  5. Click Edit -> Project
  6. Add a new tool: Click +, define tool at 10mm length 0.5mm diameter. Make note of the tool number!
  7. Open your NC file and find out what tool it's expecting to find. Towards the top you'll see the T command. Maybe T16?
  8. In the NC file, change the T# to match the tool you just created in OpenSCAM. Save your NC file. You will notice OpenSCAM re-rendering the toolpaths to accomdate the change in cutter size.
  9. Switching back over to OpenSCAM: Click the 'Play Button' under the 'Animate Toolpath' Section.
  10. Watch in amazement!
  11. If you are impatient, click the fast forward button, directly to the right of the 'Play button' to speed things up.

Run your job with Universal Gcode Sender

  1. Browse for the NC file we just simulated
  2. next step...

Software Links

  1. Inkscape
  2. HeeksCNC
  3. OpenSCAM


Next: Basic_workflow_3D